summaryrefslogtreecommitdiff
path: root/community/haskell-regex-compat/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-08-11 01:21:34 -0700
committerroot <root@rshg054.dnsready.net>2013-08-11 01:21:34 -0700
commit18a41d682d6e91e0d28fce23eb75292f477bd620 (patch)
treebce8f660d7d0b6541cadbc49bf1bac2434e4c0c6 /community/haskell-regex-compat/PKGBUILD
parent0ade1da67addf154d93c6a6399b0a3d5a18a3336 (diff)
Sun Aug 11 01:21:31 PDT 2013
Diffstat (limited to 'community/haskell-regex-compat/PKGBUILD')
-rw-r--r--community/haskell-regex-compat/PKGBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/community/haskell-regex-compat/PKGBUILD b/community/haskell-regex-compat/PKGBUILD
deleted file mode 100644
index fc0738ada..000000000
--- a/community/haskell-regex-compat/PKGBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# $Id: PKGBUILD 89316 2013-04-28 16:52:38Z td123 $
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
-# Contributor: Vesa Kaihlavirta <vesa@archlinux.org>
-# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
-
-_hkgname=regex-compat
-pkgname=haskell-regex-compat
-pkgver=0.95.1
-pkgrel=5
-pkgdesc='Replaces and enhances Text.Regex'
-url="http://hackage.haskell.org/package/${_hkgname}"
-license=('custom:BSD3')
-arch=('x86_64' 'i686')
-depends=('ghc=7.6.3-1' 'sh' 'haskell-regex-base=0.93.2' 'haskell-regex-posix=0.95.2')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-install=${pkgname}.install
-sha256sums=('d57cb1a5a4d66753b18eaa37a1621246f660472243b001894f970037548d953b')
-
-build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared --prefix=/usr \
- --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
-}
-
-package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
-}
-
-# vim:set ts=2 sw=2 et: