summaryrefslogtreecommitdiff
path: root/community/intellij-idea-libs/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-08-13 01:33:19 -0700
committerroot <root@rshg054.dnsready.net>2013-08-13 01:33:19 -0700
commit7a65a910b77ad191d69881098c47f9b0c852d92e (patch)
tree9564e611af1442f8952a8cbddb3b0ad25ed71aab /community/intellij-idea-libs/PKGBUILD
parent60da6abff6c9577a783d72865f11de7a585e912e (diff)
Tue Aug 13 01:31:08 PDT 2013
Diffstat (limited to 'community/intellij-idea-libs/PKGBUILD')
-rw-r--r--community/intellij-idea-libs/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/intellij-idea-libs/PKGBUILD b/community/intellij-idea-libs/PKGBUILD
new file mode 100644
index 000000000..e77686bc4
--- /dev/null
+++ b/community/intellij-idea-libs/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 92669 2013-06-11 16:29:42Z andrea $
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=intellij-idea-libs
+pkgver=12.1.4
+_pkgver=129.713
+pkgrel=1
+pkgdesc="Architecture dependend libraries needed by the Intellij Idea IDE"
+arch=('i686' 'x86_64')
+url="http://www.jetbrains.org/"
+license=('apache')
+depends=('glibc')
+options=(!strip)
+source=(http://download.jetbrains.com/idea/ideaIC-$pkgver.tar.gz)
+md5sums=('573815dd7dbb6a66c19f7f77a1bb048f')
+
+package() {
+ install -d -m755 "$pkgdir/usr/share/intellijidea-ce/bin"
+ install -d -m755 "$pkgdir/usr/lib"
+
+ [ $CARCH == "x86_64" ] && SUFFIX=64
+ install -m755 "idea-IC-$_pkgver"/bin/fsnotifier${SUFFIX} "$pkgdir"/usr/share/intellijidea-ce/bin/
+ install -m644 "idea-IC-$_pkgver"/bin/libbreakgen${SUFFIX}.so "$pkgdir"/usr/lib
+}
+
+# vim:set ts=2 sw=2 et: