summaryrefslogtreecommitdiff
path: root/community/kdenlive/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-08-11 01:21:34 -0700
committerroot <root@rshg054.dnsready.net>2013-08-11 01:21:34 -0700
commit18a41d682d6e91e0d28fce23eb75292f477bd620 (patch)
treebce8f660d7d0b6541cadbc49bf1bac2434e4c0c6 /community/kdenlive/PKGBUILD
parent0ade1da67addf154d93c6a6399b0a3d5a18a3336 (diff)
Sun Aug 11 01:21:31 PDT 2013
Diffstat (limited to 'community/kdenlive/PKGBUILD')
-rw-r--r--community/kdenlive/PKGBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/community/kdenlive/PKGBUILD b/community/kdenlive/PKGBUILD
deleted file mode 100644
index 87705015f..000000000
--- a/community/kdenlive/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id: PKGBUILD 92336 2013-06-04 05:10:18Z svenstaro $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: Zuf <kontakt.zuf@gmail.com>
-# Contributor: Darwin Bautista <djclue917@gmail.com>
-
-pkgname=kdenlive
-pkgver=0.9.6
-pkgrel=2
-pkgdesc="A non-linear video editor for Linux"
-arch=('i686' 'x86_64')
-# http://download.kde.org/stable/kdenlive/
-url="http://www.kdenlive.org/"
-license=('GPL')
-depends=('kdebase-runtime' 'mlt' 'qjson' 'libqzeitgeist')
-makedepends=('automoc4' 'cmake' 'gettext' 'mesa' 'glu')
-optdepends=('recordmydesktop: screen capture'
- 'dvdauthor: dvd creation'
- 'dvgrab: firewire capture'
- 'xine-ui: dvd preview'
- 'cdrkit: dvd iso image creation')
-install=kdenlive.install
-options=('docs')
-source=(http://download.kde.org/stable/kdenlive/$pkgver/src/kdenlive-$pkgver.tar.bz2)
-md5sums=('3bd3a511b860490acc367e7c9d7ffa43')
-
-build() {
- export LDFLAGS="$LDFLAGS -lX11"
- cd "${srcdir}"
- mkdir -p build
- cd build
- cmake ../kdenlive-${pkgver} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=/usr/lib \
- -DLINK_LIBRARIES=-lX11
- make
-}
-
-package() {
- cd "${srcdir}"/build
- make DESTDIR="${pkgdir}" install
-}