summaryrefslogtreecommitdiff
path: root/community/kdenlive/PKGBUILD
diff options
context:
space:
mode:
authorParabola <dev@list.parabolagnulinux.org>2011-04-05 14:26:38 +0000
committerParabola <dev@list.parabolagnulinux.org>2011-04-05 14:26:38 +0000
commit415856bdd4f48ab4f2732996f0bae58595092bbe (patch)
treeede2018b591f6dfb477fe9341ba17b9bc000fab9 /community/kdenlive/PKGBUILD
Tue Apr 5 14:26:38 UTC 2011
Diffstat (limited to 'community/kdenlive/PKGBUILD')
-rw-r--r--community/kdenlive/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/kdenlive/PKGBUILD b/community/kdenlive/PKGBUILD
new file mode 100644
index 000000000..70e1ab84c
--- /dev/null
+++ b/community/kdenlive/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 43713 2011-03-29 10:19:44Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Zuf <kontakt.zuf@gmail.com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+
+pkgname=kdenlive
+pkgver=0.7.8
+pkgrel=3
+pkgdesc="A non-linear video editor for Linux"
+arch=('i686' 'x86_64')
+url="http://www.kdenlive.org/"
+license=('GPL')
+depends=('kdebase-runtime' 'mlt' 'dvgrab')
+makedepends=('automoc4' 'cmake' 'gettext')
+install=kdenlive.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('7011d0c6b26f7f2350065defef3d9a76')
+
+build() {
+ export LDFLAGS="$LDFLAGS -lX11"
+
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib \
+ -DLINK_LIBRARIES=-lX11
+ make
+}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="${pkgdir}" install
+}