summaryrefslogtreecommitdiff
path: root/community/kdenlive/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-07-19 01:10:32 -0700
committerroot <root@rshg054.dnsready.net>2013-07-19 01:10:32 -0700
commit8fbc0076a4827ddc6af92e0b9daa4c4c31450808 (patch)
tree03fd0e2921ebd53228d9a93e32ed3976b636cbea /community/kdenlive/PKGBUILD
parente445a313723389ba9ee1fded025c567dae5b21ea (diff)
Fri Jul 19 01:09:18 PDT 2013
Diffstat (limited to 'community/kdenlive/PKGBUILD')
-rw-r--r--community/kdenlive/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/kdenlive/PKGBUILD b/community/kdenlive/PKGBUILD
new file mode 100644
index 000000000..87705015f
--- /dev/null
+++ b/community/kdenlive/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 92336 2013-06-04 05:10:18Z svenstaro $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Zuf <kontakt.zuf@gmail.com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+
+pkgname=kdenlive
+pkgver=0.9.6
+pkgrel=2
+pkgdesc="A non-linear video editor for Linux"
+arch=('i686' 'x86_64')
+# http://download.kde.org/stable/kdenlive/
+url="http://www.kdenlive.org/"
+license=('GPL')
+depends=('kdebase-runtime' 'mlt' 'qjson' 'libqzeitgeist')
+makedepends=('automoc4' 'cmake' 'gettext' 'mesa' 'glu')
+optdepends=('recordmydesktop: screen capture'
+ 'dvdauthor: dvd creation'
+ 'dvgrab: firewire capture'
+ 'xine-ui: dvd preview'
+ 'cdrkit: dvd iso image creation')
+install=kdenlive.install
+options=('docs')
+source=(http://download.kde.org/stable/kdenlive/$pkgver/src/kdenlive-$pkgver.tar.bz2)
+md5sums=('3bd3a511b860490acc367e7c9d7ffa43')
+
+build() {
+ export LDFLAGS="$LDFLAGS -lX11"
+ cd "${srcdir}"
+ mkdir -p build
+ cd build
+ cmake ../kdenlive-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib \
+ -DLINK_LIBRARIES=-lX11
+ make
+}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="${pkgdir}" install
+}