summaryrefslogtreecommitdiff
path: root/community/libnfnetlink/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2011-09-15 23:14:42 +0000
committerroot <root@rshg054.dnsready.net>2011-09-15 23:14:42 +0000
commit062d1ba2c4d5de52d97f339c5a3ac1199b8533f6 (patch)
treebd00d2e476e1761b3771b1849a3a207dd8cb5c57 /community/libnfnetlink/PKGBUILD
parentd5effc9aadfb9ed5890376ca9497eef52fafcf83 (diff)
Thu Sep 15 23:14:42 UTC 2011
Diffstat (limited to 'community/libnfnetlink/PKGBUILD')
-rw-r--r--community/libnfnetlink/PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/libnfnetlink/PKGBUILD b/community/libnfnetlink/PKGBUILD
index 17e77c144..fc8e6d8dd 100644
--- a/community/libnfnetlink/PKGBUILD
+++ b/community/libnfnetlink/PKGBUILD
@@ -1,22 +1,27 @@
-# $Id: PKGBUILD 191 2009-07-20 09:12:55Z spupykin $
+# $Id: PKGBUILD 55539 2011-09-14 08:04:26Z andrea $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Kevin Edmonds <edmondskevin@hotmail.com>
-# Maintainer: Filip Wojciechowski, filip at loka dot pl
+# Contributor: Filip Wojciechowski, filip at loka dot pl
+
pkgname=libnfnetlink
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="low-level library for netfilter related kernel/userspace communication"
-depends=(glibc)
+arch=('i686' 'x86_64')
url="http://www.netfilter.org/projects/libnfnetlink/index.html"
license=('GPL')
-arch=('i686' 'x86_64')
+depends=('glibc')
options=('!libtool')
-source=(http://www.netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2)
+source=("http://www.netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2")
md5sums=('016fdec8389242615024c529acc1adb8')
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ make DESTDIR="${pkgdir}" install
}