summaryrefslogtreecommitdiff
path: root/community/mpv/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-09-04 02:15:19 -0700
committerroot <root@rshg054.dnsready.net>2013-09-04 02:15:19 -0700
commitc270fd5b2cd42b593708a919254fbbb609bbf641 (patch)
tree2cc8a32b6fe3260814e158bb8b18abec1a09e18d /community/mpv/PKGBUILD
parent3aa73e2018f321c9ccff8eca801b1c2fa9f18fa8 (diff)
Wed Sep 4 02:13:41 PDT 2013
Diffstat (limited to 'community/mpv/PKGBUILD')
-rw-r--r--community/mpv/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/mpv/PKGBUILD b/community/mpv/PKGBUILD
new file mode 100644
index 000000000..87eb5686c
--- /dev/null
+++ b/community/mpv/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 96700 2013-09-03 06:44:12Z bpiotrowski $
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: Eivind Uggedal <eivind@uggedal.com>
+
+pkgname=mpv
+pkgver=0.1.4
+pkgrel=4
+pkgdesc='Video player based on MPlayer/mplayer2'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://mpv.io'
+depends=('portaudio' 'ffmpeg' 'lcms2' 'libxinerama' 'libquvi' 'mpg123' 'libxv' 'libxkbcommon' 'libva')
+makedepends=('mesa' 'python-docutils')
+options=(!emptydirs)
+source=("https://github.com/mpv-player/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('7a0ff10fb0c6a2a8c176d40883eb09d4')
+
+build() {
+ unset CFLAGS
+ unset LDFLAGS
+
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --confdir=/etc/mpv \
+ --disable-lircc \
+ --disable-joystick \
+ --disable-radio \
+ --disable-radio-capture \
+ --disable-radio-v4l2 \
+ --disable-rpath \
+ --disable-libbs2b \
+ --disable-direct3d \
+ --disable-corevideo \
+ --disable-cocoa \
+ --disable-coreaudio
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make -j1 DESTDIR="$pkgdir" install
+
+ install -d $pkgdir/usr/share/doc/mpv/examples
+ install -m644 etc/{input,example,encoding-example-profiles}.conf \
+ "$pkgdir"/usr/share/doc/mpv/examples
+ install -m644 DOCS/{encoding.rst,tech-overview.txt} \
+ "$pkgdir"/usr/share/doc/mpv
+ install -m755 TOOLS/mpv_identify.sh "$pkgdir"/usr/bin
+}