summaryrefslogtreecommitdiff
path: root/community/mythtv/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2011-10-23 23:14:59 +0000
committerroot <root@rshg054.dnsready.net>2011-10-23 23:14:59 +0000
commitc0bc46632845dfc241d3290d8d3193287eaeb02e (patch)
tree15e467e4985d599a312014b62fd555cbc4cdffc7 /community/mythtv/PKGBUILD
parent789905b5e6b809a564832ba85b842988405e7375 (diff)
Sun Oct 23 23:14:58 UTC 2011
Diffstat (limited to 'community/mythtv/PKGBUILD')
-rw-r--r--community/mythtv/PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/mythtv/PKGBUILD b/community/mythtv/PKGBUILD
index 5fb175253..843136c80 100644
--- a/community/mythtv/PKGBUILD
+++ b/community/mythtv/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 48169 2011-05-29 12:28:03Z jconder $
+# $Id: PKGBUILD 57172 2011-10-23 02:27:54Z jconder $
# Maintainer: Jonathan Conder <jonno.conder@gmail.com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Juergen Hoetzel <juergen@archlinux.org>
@@ -7,7 +7,7 @@
pkgname=mythtv
pkgver=0.24.1
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ license=('GPL')
depends=('lame' 'libavc1394' 'libiec61883' 'libpulse' 'libvdpau' 'libxinerama'
'libxvmc' 'lirc-utils' 'mesa' 'mysql-clients' 'mysql-python'
'perl-dbd-mysql' 'perl-libwww' 'perl-net-upnp' 'python-lxml' 'qt'
- 'wget')
+ 'qtwebkit' 'wget')
makedepends=('yasm')
optdepends=('xmltv: to download tv listings')
backup=('etc/conf.d/mythbackend')
@@ -24,17 +24,20 @@ install='mythtv.install'
source=("ftp://ftp.osuosl.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2"
'mythbackend.rc'
'mythbackend.conf'
- 'mythtv-v4l2-fix.patch')
+ 'mythtv-v4l2-fix.patch'
+ 'build.patch')
md5sums=('6870c679619ec58456e76839745411d8'
'feadcc9ad064d93d6dceab1efc0bd9ed'
'bb8e4033d82428d827570fae9ba15e6a'
- 'ba5c91df80f0d3f7563a873e71a3725c')
+ 'ba5c91df80f0d3f7563a873e71a3725c'
+ '3188962917e98c4e07818dccd64bc423')
build() {
cd "$srcdir/$pkgname-$pkgver"
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
patch -Np2 -i ${srcdir}/mythtv-v4l2-fix.patch
+ patch -Np1 -i ${srcdir}/build.patch
ARCH="${CARCH/_/-}"
./configure --prefix=/usr --cpu="$ARCH" \