summaryrefslogtreecommitdiff
path: root/community/nemo/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-08-15 01:55:49 -0700
committerroot <root@rshg054.dnsready.net>2013-08-15 01:55:49 -0700
commit67142d22ee558cc14309b0a3d372ed796ae8d545 (patch)
treec5438425fb356422d27df30dd9896407e397ca33 /community/nemo/PKGBUILD
parent35ddd3815641e4564d75c5b402f7f0cf48628167 (diff)
Thu Aug 15 01:55:47 PDT 2013
Diffstat (limited to 'community/nemo/PKGBUILD')
-rw-r--r--community/nemo/PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/community/nemo/PKGBUILD b/community/nemo/PKGBUILD
index 5c3cab47f..8e04eb820 100644
--- a/community/nemo/PKGBUILD
+++ b/community/nemo/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 94000 2013-07-12 22:37:49Z faidoc $
+# $Id: PKGBUILD 95581 2013-08-14 15:07:17Z bgyorgy $
# Maintainer: Alexandre Filgueira <alexfilgueira@cinnarch.com>
# Contributor: Ner0
pkgname=nemo
pkgver=1.8.4
-pkgrel=1
+pkgrel=3
pkgdesc="Cinnamon file manager (Nautilus fork)"
arch=('i686' 'x86_64')
url="https://github.com/linuxmint/nemo"
@@ -48,4 +48,15 @@ package() {
cd linuxmint-nemo-*
make DESTDIR="$pkgdir/" install
+
+ # Rename 'Files' app name to avoid having the same as nautilus
+ sed -i 's/^Name\(.*\)=.*/Name\1=Nemo/' "$pkgdir/usr/share/applications/nemo.desktop"
+
+ # Autostart only in Cinnamon to avoid conflict with GNOME Classic session
+ cp "$pkgdir/etc/xdg/autostart/nemo-autostart.desktop" \
+ "$pkgdir/etc/xdg/autostart/nemo-autostart2d.desktop"
+ sed -i 's/^AutostartCondition=.*/AutostartCondition=GNOME3 if-session cinnamon/' \
+ "$pkgdir/etc/xdg/autostart/nemo-autostart.desktop"
+ sed -i 's/^AutostartCondition=.*/AutostartCondition=GNOME3 if-session cinnamon2d/' \
+ "$pkgdir/etc/xdg/autostart/nemo-autostart2d.desktop"
}