summaryrefslogtreecommitdiff
path: root/community/nemo/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-05-10 03:49:37 +0000
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-05-10 03:49:37 +0000
commitbf8ca82240123cfd3e65739dc2318f5f1d145d12 (patch)
treeb8320743e13c3a3de7a54a217ec30970c6336706 /community/nemo/PKGBUILD
parent66018e3cb2f893ec3add478fcd86ed3334e46fa9 (diff)
Sat May 10 03:41:34 UTC 2014
Diffstat (limited to 'community/nemo/PKGBUILD')
-rw-r--r--community/nemo/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/nemo/PKGBUILD b/community/nemo/PKGBUILD
index f111feb4d..9105e60b9 100644
--- a/community/nemo/PKGBUILD
+++ b/community/nemo/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 110568 2014-05-03 18:14:08Z faidoc $
+# $Id: PKGBUILD 110928 2014-05-09 20:22:46Z bgyorgy $
# Maintainer: Alexandre Filgueira <alexfilgueira@cinnarch.com>
# Contributor: Ner0
pkgname=nemo
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Cinnamon file manager (Nautilus fork)"
arch=('i686' 'x86_64')
url="https://github.com/linuxmint/nemo"
@@ -23,13 +23,17 @@ sha256sums=('c0bc5cc0340a99bca8eab3f8312839f8d3e96cf29326ded919c948781694c2d3'
prepare() {
cd linuxmint-nemo-*
- # Fix white text on breadcrumb with Adwaita theme
- patch -Np1 -i ../adwaita_style.patch
-
# Python2 fix
sed -i 's/bin\/python/bin\/python2/g' files/usr/share/nemo/actions/myaction.py
find -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+ # Fix white text on breadcrumb with Adwaita theme
+ patch -Np1 -i ../adwaita_style.patch
+
+ # Fix desktop style with Adwaita theme
+ sed -i 's/add_class (\(.*\), "nemo-/add_class (\1, "nautilus-/' \
+ libnemo-private/nemo-icon-{canvas-item,container}.c
+
# Fix build
sed -i '/AC_SUBST(DISABLE_DEPRECATED_CFLAGS)/d' configure.in
@@ -44,7 +48,6 @@ build() {
--localstatedir=/var --disable-static \
--libexecdir=/usr/lib/nemo \
--disable-update-mimedb \
- --disable-packagekit \
--disable-tracker \
--disable-gtk-doc-html \
--disable-schemas-compile