summaryrefslogtreecommitdiff
path: root/community/python-sqlalchemy/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-07-24 03:36:08 +0000
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-07-24 03:36:08 +0000
commitd256eaa80219eb28cbfb4f9474acc6fb41c63d3c (patch)
treed4752710a1a201081be416a2e43ea85947d67140 /community/python-sqlalchemy/PKGBUILD
parentff9e4e102459123bc5bf56965828ebb81081d37f (diff)
Thu Jul 24 03:31:46 UTC 2014
Diffstat (limited to 'community/python-sqlalchemy/PKGBUILD')
-rw-r--r--community/python-sqlalchemy/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/python-sqlalchemy/PKGBUILD b/community/python-sqlalchemy/PKGBUILD
index ed45e185b..863a0c71d 100644
--- a/community/python-sqlalchemy/PKGBUILD
+++ b/community/python-sqlalchemy/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 113477 2014-06-24 04:09:38Z fyan $
+# $Id: PKGBUILD 116139 2014-07-23 05:47:43Z fyan $
# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Maintainer: Felix Yan <felixonmars@gmail.com>
# Contributor: Sébastien Luttringer <seblu@aur.archlinux.org>
pkgbase=python-sqlalchemy
pkgname=('python-sqlalchemy' 'python2-sqlalchemy')
-pkgver=0.9.6
+pkgver=0.9.7
pkgrel=1
arch=('i686' 'x86_64') # python2 package contain .so
url="http://www.sqlalchemy.org/"
@@ -13,7 +13,7 @@ license=('MIT')
makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
checkdepends=('python-pytest' 'python2-pytest' 'python-mock' 'python2-mock')
source=("https://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-$pkgver.tar.gz")
-md5sums=('f8494d85834ba6a465b4a32078d36ee8')
+md5sums=('e3c8f836ea9b48886718f59b9d8646ff')
prepare() {
cp -a SQLAlchemy-$pkgver SQLAlchemy2-$pkgver
@@ -29,10 +29,10 @@ build() {
check() {
cd SQLAlchemy-${pkgver}
- python setup.py test || warning "Tests failed"
+ PYTHONPATH="$(pwd)/build/lib.linux-$CARCH-3.4:$PYTHONPATH" py.test
cd ../SQLAlchemy2-$pkgver
- python2 setup.py test || warning "Tests failed"
+ PYTHONPATH="$(pwd)/build/lib.linux-$CARCH-2.7:$PYTHONPATH" py.test2
}
package_python-sqlalchemy() {