summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-11-04 01:27:27 -0800
committerroot <root@rshg054.dnsready.net>2013-11-04 01:27:27 -0800
commit058983fb5cb16dbb25368dd464cbcf27205b3f93 (patch)
tree4f07b3aba435304aac5c5f93e5a9784031dabd40 /core/curl/PKGBUILD
parent1ce58386c5ee7086ac6848f35cade5d45bf86764 (diff)
Mon Nov 4 01:26:54 PST 2013
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 384e163d9..0c88797cf 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 197806 2013-10-30 11:02:54Z allan $
+# $Id: PKGBUILD 198761 2013-11-03 13:49:41Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -7,7 +7,7 @@
pkgname=curl
pkgver=7.33.0
-pkgrel=2
+pkgrel=3
pkgdesc="An URL retrieval utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
@@ -16,11 +16,19 @@ depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
provides=('libcurl.so')
options=('strip' 'debug')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
+ "0001-glob-fix-regression-from-commit-5ca96cb844.patch::https://github.com/bagder/curl/commit/867b52a.patch"
curlbuild.h)
md5sums=('c8a4eaac7ce7b0d1bf458d62ccd4ef93'
'SKIP'
+ 'd71c7eab7d38f1731f78285634a4c390'
'751bd433ede935c8fae727377625a8ae')
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -Np1 < "$srcdir"/0001-glob-fix-regression-from-commit-5ca96cb844.patch
+}
+
build() {
cd "$pkgname-$pkgver"