summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-02-13 00:04:32 -0800
committerroot <root@rshg054.dnsready.net>2013-02-13 00:04:32 -0800
commit0671250710c3e7312a4693ac45ebbaacf471d1dc (patch)
treef40a26f2fd5267582cf25a84886471773bc160c8 /core/curl/PKGBUILD
parent29b0da64a462b6c5f6871b08e344b3ffa59cbd0a (diff)
Wed Feb 13 00:04:27 PST 2013
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 1c0f41e45..51d860f43 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 177786 2013-02-08 18:18:03Z dreisner $
+# $Id: PKGBUILD 177958 2013-02-12 13:57:28Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -7,7 +7,7 @@
pkgname=curl
pkgver=7.29.0
-pkgrel=1
+pkgrel=2
pkgdesc="An URL retrieval utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
@@ -15,9 +15,11 @@ license=('MIT')
depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
options=('!libtool')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
+ 0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch
curlbuild.h)
md5sums=('4f57d3b4a3963038bd5e04dbff385390'
'6283fbb36933cf8720acc34c43169f1d'
+ '5bfd1899e8b19cfdd78774f6337f8b47'
'751bd433ede935c8fae727377625a8ae')
ptrsize=$(cpp <<<'__SIZEOF_POINTER__' | sed '/^#/d')
@@ -32,6 +34,8 @@ esac
build() {
cd "$pkgname-$pkgver"
+ patch -Np1 <"$srcdir/0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch"
+
./configure \
--prefix=/usr \
--mandir=/usr/share/man \