summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-01-15 03:49:32 +0000
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-01-15 03:49:32 +0000
commit154321f7346db5c32dbdf9c730735969eabbd88f (patch)
treec89badf5b9547f313d7b28a7f400c3df404af70f /core/curl/PKGBUILD
parent271da49386e259723ef574713339f04886630604 (diff)
Wed Jan 15 03:43:12 UTC 2014
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 3ea9f4915..929275905 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 203041 2014-01-02 14:43:46Z dreisner $
+# $Id: PKGBUILD 204043 2014-01-14 15:06:13Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -7,19 +7,21 @@
pkgname=curl
pkgver=7.34.0
-pkgrel=2
+pkgrel=3
pkgdesc="An URL retrieval utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
license=('MIT')
-depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
+depends=('ca-certificates' 'krb5' 'libssh2' 'openssl' 'zlib')
provides=('libcurl.so')
options=('strip' 'debug')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
+ 0001-FILE-don-t-wait-due-to-CURLOPT_MAX_RECV_SPEED_LARGE.patch
0001-connect-Try-all-addresses-in-first-connection-attemp.patch
curlbuild.h)
md5sums=('d5b7edccbd1793e3549842e01331da20'
'SKIP'
+ 'ba766acdb7568aac0b23d479ebecd591'
'ee755b0e886207fc1e8154e426c46ca7'
'751bd433ede935c8fae727377625a8ae')
@@ -27,6 +29,7 @@ prepare() {
cd "$pkgname-$pkgver"
patch -Np1 <"$srcdir"/0001-connect-Try-all-addresses-in-first-connection-attemp.patch
+ patch -Np1 <"$srcdir"/0001-FILE-don-t-wait-due-to-CURLOPT_MAX_RECV_SPEED_LARGE.patch
}
build() {
@@ -41,6 +44,7 @@ build() {
--enable-manual \
--enable-versioned-symbols \
--enable-threaded-resolver \
+ --with-gssapi \
--without-libidn \
--with-random=/dev/urandom \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt