summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2011-11-23 23:15:26 +0000
committerroot <root@rshg054.dnsready.net>2011-11-23 23:15:26 +0000
commit1e1e4927b05d9b242bfe83794e3a98ab2c8f79ef (patch)
tree070846cb6770ab17d394d88c3f0cd3ad3eb89842 /core/curl/PKGBUILD
parent851ab9aa99e9bda38f88b5f5ade096c9137e11c8 (diff)
Wed Nov 23 23:15:26 UTC 2011
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index dafb0b22d..e39cc6cf3 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 143006 2011-11-20 14:43:34Z dreisner $
+# $Id: PKGBUILD 143109 2011-11-23 02:58:17Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -7,7 +7,7 @@
pkgname=curl
pkgver=7.23.1
-pkgrel=1
+pkgrel=2
pkgdesc="An URL retrival utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
@@ -16,9 +16,11 @@ depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
makedepends=('perl-libwww')
options=('!libtool')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
+ fix-J-with-O-regression.patch
curlbuild.h)
md5sums=('8e23151f569fb54afef093ac0695077d'
'5d8eb7e2e38be0fb00a043f714f6d49f'
+ 'aa4539ec4f4a2dad1663dc22dd3ab0a1'
'751bd433ede935c8fae727377625a8ae')
ptrsize=$(cpp <<<'__SIZEOF_POINTER__' | sed '/^#/d')
@@ -33,6 +35,10 @@ esac
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # upstream bugfix
+ # http://curl.haxx.se/mail/archive-2011-11/0030.html
+ patch -Np1 < "$srcdir/fix-J-with-O-regression.patch"
+
./configure \
--prefix=/usr \
--mandir=/usr/share/man \