summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2012-01-26 23:14:55 +0000
committerroot <root@rshg054.dnsready.net>2012-01-26 23:14:55 +0000
commit3741146d50cb93e8985f8aac937e36d35ee76446 (patch)
tree98628c2ca15482ec0c66a81db48b4ddd777e1136 /core/curl/PKGBUILD
parenta61c6fb05ec1cbc6845b2ed4077ce0c5950c36ed (diff)
Thu Jan 26 23:14:55 UTC 2012
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index e39cc6cf3..6ce1c9c25 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 143109 2011-11-23 02:58:17Z dreisner $
+# $Id: PKGBUILD 147269 2012-01-25 13:57:06Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -6,20 +6,19 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=curl
-pkgver=7.23.1
-pkgrel=2
+pkgver=7.24.0
+pkgrel=1
pkgdesc="An URL retrival utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
license=('MIT')
depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
-makedepends=('perl-libwww')
options=('!libtool')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
fix-J-with-O-regression.patch
curlbuild.h)
-md5sums=('8e23151f569fb54afef093ac0695077d'
- '5d8eb7e2e38be0fb00a043f714f6d49f'
+md5sums=('b93420f80a2baaa61a0f45214eddc2ba'
+ '710242df6bc318d16eea611e7d1b1410'
'aa4539ec4f4a2dad1663dc22dd3ab0a1'
'751bd433ede935c8fae727377625a8ae')
@@ -33,11 +32,7 @@ case $ptrsize in
esac
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # upstream bugfix
- # http://curl.haxx.se/mail/archive-2011-11/0030.html
- patch -Np1 < "$srcdir/fix-J-with-O-regression.patch"
+ cd "$pkgname-$pkgver"
./configure \
--prefix=/usr \
@@ -52,11 +47,12 @@ build() {
--without-libidn \
--with-random=/dev/urandom \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install