summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-04-16 00:06:15 -0700
committerroot <root@rshg054.dnsready.net>2013-04-16 00:06:15 -0700
commit975d6f489c6c43bbc7b816ac43333c54c1f4df21 (patch)
treee10299091457df6104611a2b54c3a27cdbeab49b /core/curl/PKGBUILD
parenta196f69321b722259bed2cc63e6f64a5cb0b8389 (diff)
Tue Apr 16 00:06:15 PDT 2013
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD32
1 files changed, 14 insertions, 18 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 51d860f43..cda53a9cc 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 177958 2013-02-12 13:57:28Z dreisner $
+# $Id: PKGBUILD 182802 2013-04-15 12:46:55Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -6,8 +6,8 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=curl
-pkgver=7.29.0
-pkgrel=2
+pkgver=7.30.0
+pkgrel=1
pkgdesc="An URL retrieval utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
@@ -15,27 +15,14 @@ license=('MIT')
depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
options=('!libtool')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
- 0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch
curlbuild.h)
-md5sums=('4f57d3b4a3963038bd5e04dbff385390'
- '6283fbb36933cf8720acc34c43169f1d'
- '5bfd1899e8b19cfdd78774f6337f8b47'
+md5sums=('60bb6ff558415b73ba2f00163fd307c5'
+ 'SKIP'
'751bd433ede935c8fae727377625a8ae')
-ptrsize=$(cpp <<<'__SIZEOF_POINTER__' | sed '/^#/d')
-case $ptrsize in
- 8) _curlbuild=curlbuild-64.h ;;
- 4) _curlbuild=curlbuild-32.h ;;
- *) error "unknown pointer size for architecture: %s bytes" "$ptrsize"
- exit 1
- ;;
-esac
-
build() {
cd "$pkgname-$pkgver"
- patch -Np1 <"$srcdir/0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch"
-
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -58,6 +45,15 @@ package() {
make DESTDIR="$pkgdir" install
+ local ptrsize=$(cpp <<<'__SIZEOF_POINTER__' | sed '/^#/d')
+ case $ptrsize in
+ 8) _curlbuild=curlbuild-64.h ;;
+ 4) _curlbuild=curlbuild-32.h ;;
+ *) error "unknown pointer size for architecture: %s bytes" "$ptrsize"
+ exit 1
+ ;;
+ esac
+
# license
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"