summaryrefslogtreecommitdiff
path: root/core/curl/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-01-03 03:19:39 +0000
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-01-03 03:19:39 +0000
commitf72cb0ced39aca827b5269eba5455dbf846410e2 (patch)
tree7047d64bf11194dc5e44ed4f6765ffccb11676cf /core/curl/PKGBUILD
parent3cbc40e327b77b23d48f55c76c0efde35a5dad16 (diff)
Fri Jan 3 03:17:00 UTC 2014
Diffstat (limited to 'core/curl/PKGBUILD')
-rw-r--r--core/curl/PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 06a7b278f..3ea9f4915 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 202635 2013-12-23 02:04:37Z dreisner $
+# $Id: PKGBUILD 203041 2014-01-02 14:43:46Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
@@ -7,7 +7,7 @@
pkgname=curl
pkgver=7.34.0
-pkgrel=1
+pkgrel=2
pkgdesc="An URL retrieval utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
@@ -16,11 +16,19 @@ depends=('ca-certificates' 'libssh2' 'openssl' 'zlib')
provides=('libcurl.so')
options=('strip' 'debug')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
+ 0001-connect-Try-all-addresses-in-first-connection-attemp.patch
curlbuild.h)
md5sums=('d5b7edccbd1793e3549842e01331da20'
'SKIP'
+ 'ee755b0e886207fc1e8154e426c46ca7'
'751bd433ede935c8fae727377625a8ae')
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -Np1 <"$srcdir"/0001-connect-Try-all-addresses-in-first-connection-attemp.patch
+}
+
build() {
cd "$pkgname-$pkgver"