summaryrefslogtreecommitdiff
path: root/extra/ghc/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg047.dnsready.net>2011-06-27 23:06:15 +0000
committerroot <root@rshg047.dnsready.net>2011-06-27 23:06:15 +0000
commit0a595245dd258cc0ad9a5de2b292cf1b1a94f51a (patch)
tree2cbc26bebf7171db78c67303e24ad6e80279f2d8 /extra/ghc/PKGBUILD
parent715631caf52784c47c8ed3aeb6cbdba2715a08db (diff)
Mon Jun 27 23:06:14 UTC 2011
Diffstat (limited to 'extra/ghc/PKGBUILD')
-rw-r--r--extra/ghc/PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/extra/ghc/PKGBUILD b/extra/ghc/PKGBUILD
index 19887fef4..9fddba6ca 100644
--- a/extra/ghc/PKGBUILD
+++ b/extra/ghc/PKGBUILD
@@ -1,14 +1,20 @@
-# $Id: PKGBUILD 112131 2011-03-04 07:57:42Z vesa $
+# $Id: PKGBUILD 128106 2011-06-22 10:54:11Z vesa $
# Maintainer: Vesa Kaihlavirta <vesa@archlinux.org>
+# Special note for devs looking to upgrade this package:
+# ghc places a unique hash for each library when it is built.
+# Libraries depend on versions specified by those hashes.
+# This implies that all libraries need to be rebuilt when ghc is rebuilt.
+# Also, due to dependency loop problems, haskell-ghc-paths and haddock
+# do not carry version dependencies. You will have to remember to build them too.
pkgname=ghc
-pkgver=7.0.2
-pkgrel=1
+pkgver=7.0.3
+pkgrel=2
pkgdesc="The Glasgow Haskell Compiler"
arch=(i686 x86_64)
url="http://www.haskell.org/ghc/"
license=("custom")
depends=('perl' 'gmp>=5.0' gcc)
-makedepends=(ghc happy perl)
+makedepends=(ghc happy perl libxslt docbook-xsl)
provides=("haskell-array=0.3.0.2"
"haskell-bytestring=0.9.1.10"
"haskell-cabal=1.10.1.0"
@@ -26,7 +32,6 @@ provides=("haskell-array=0.3.0.2"
"haskell-template-haskell=2.5.0.0"
"haskell-time=1.2.0.3"
"haskell-unix=2.4.2.0"
- "haddock=2.9.2"
)
replaces=("haskell-array<0.3.0.2"
"haskell-bytestring<0.9.1.10"
@@ -45,11 +50,10 @@ replaces=("haskell-array<0.3.0.2"
"haskell-template-haskell<2.5.0.0"
"haskell-time<1.2.0.3"
"haskell-unix<2.4.2.0"
- "haddock<2.9.2"
)
install=ghc.install
-
+options=(!strip)
source=("http://www.haskell.org/ghc/dist/$pkgver/ghc-$pkgver-src.tar.bz2"
build.mk)
@@ -60,10 +64,16 @@ build() {
./configure --prefix=/usr
make -j1 || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
make DESTDIR=$pkgdir install
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/ghc/license
+ install -d $pkgdir/usr/share/haskell
}
-md5sums=('946a18a0dc30437db72c0d3fdf26ca42'
+md5sums=('10bc5e9ae1b581404376efb85f260ff3'
'5a3e0880c80b1dcecf779ff2e63a9c0d')