summaryrefslogtreecommitdiff
path: root/extra/kdebase-workspace/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2013-08-20 02:15:20 -0700
committerroot <root@rshg054.dnsready.net>2013-08-20 02:15:20 -0700
commit1ae31a85e191bbf7313077b472a66d1c24af1f74 (patch)
tree91f021858c2e33e1a6633c12b80e54105fd7500b /extra/kdebase-workspace/PKGBUILD
parent26606f981048ee9efcda690b619d3c53501a7a58 (diff)
Tue Aug 20 02:14:51 PDT 2013
Diffstat (limited to 'extra/kdebase-workspace/PKGBUILD')
-rw-r--r--extra/kdebase-workspace/PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/extra/kdebase-workspace/PKGBUILD b/extra/kdebase-workspace/PKGBUILD
index 8be7c6841..4ec32198c 100644
--- a/extra/kdebase-workspace/PKGBUILD
+++ b/extra/kdebase-workspace/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 189503 2013-07-03 17:00:52Z andrea $
+# $Id: PKGBUILD 193234 2013-08-19 09:54:29Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=kdebase-workspace
_pkgname=kde-workspace
-pkgver=4.10.5
+pkgver=4.11.0
pkgrel=1
pkgdesc="Provides the interface and basic tools for the KDE workspace"
arch=('i686' 'x86_64')
@@ -18,7 +18,8 @@ depends=("kdelibs>=${pkgver}" 'kdepim-runtime' 'lm_sensors' 'libraw1394'
'qimageblitz' 'polkit-kde' 'xorg-xprop' 'libxdamage' 'libqalculate'
'libxklavier' 'xorg-xsetroot' 'libxcomposite' 'libxinerama'
'xorg-xrdb' 'libxres' 'xorg-xrandr' 'xorg-xmessage' 'libusb-compat'
- 'kde-base-artwork' 'xcb-util-renderutil' 'xcb-util-image' 'ttf-font')
+ 'kde-base-artwork' 'xcb-util-renderutil' 'xcb-util-image' 'ttf-font'
+ 'xcb-util-keysyms' 'xcb-util-wm' 'pciutils')
makedepends=('cmake' 'automoc4' 'boost' 'kdebindings-python2' 'networkmanager')
optdepends=('kde-wallpapers: wallpapers for KDE Plasma Workspaces'
'appmenu-qt: menu applications over dbus')
@@ -26,9 +27,8 @@ install="${pkgname}.install"
backup=('usr/share/config/kdm/kdmrc')
source=("http://download.kde.org/stable/${pkgver}/src/${_pkgname}-${pkgver}.tar.xz"
'kde.pam' 'kde-np.pam' 'kscreensaver.pam' 'kdm.service' 'kdm.logrotate'
- 'etc-scripts.patch' 'terminate-server.patch' 'kdm-xinitrd.patch'
- 'fix-plasma-memory-leak.patch')
-sha1sums=('d4986c1b4e3232f74a6348116908a13aee073a93'
+ 'etc-scripts.patch' 'terminate-server.patch' 'kdm-xinitrd.patch')
+sha1sums=('3e877c9f82ad4b3d10c0752adbb50240707d632d'
'660eae40a707d2711d8d7f32a93214865506b795'
'6aeecc9e0e221f0515c6bf544f9a3c11cb6961fe'
'106635aa1aae51d6f0668b1853f6c49a4fe9d3d8'
@@ -36,8 +36,7 @@ sha1sums=('d4986c1b4e3232f74a6348116908a13aee073a93'
'bbe55f2000217474ce7246f12ee437ceaaf7e9ae'
'c079ebd157c836ba996190f0d2bcea1a7828d02c'
'ac7bc292c865bc1ab8c02e6341aa7aeaf1a3eeee'
- 'd509dac592bd8b310df27991b208c95b6d907514'
- 'e453545568d20165f80b97dd270b5adc731d5f21')
+ 'd509dac592bd8b310df27991b208c95b6d907514')
prepare() {
cd ${_pkgname}-${pkgver}
@@ -49,9 +48,6 @@ prepare() {
# KDEBUG#202629
patch -p0 -i "${srcdir}"/terminate-server.patch
-
- # KDEBUG#314919
- patch -p1 -i "${srcdir}"/fix-plasma-memory-leak.patch
}
build() {
@@ -63,7 +59,6 @@ build() {
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_Xmms=OFF \
- -DWITH_Googlegadgets=OFF \
-DWITH_libgps=OFF \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DWITH_CkConnector=OFF