summaryrefslogtreecommitdiff
path: root/extra/libtorrent-rasterbar/PKGBUILD
diff options
context:
space:
mode:
authorroot <root@rshg054.dnsready.net>2012-03-07 00:01:25 +0000
committerroot <root@rshg054.dnsready.net>2012-03-07 00:01:25 +0000
commit5a680f7689b01b4b7a0bfade1a6c1f659f8cbed4 (patch)
treee7b6c472f6deee81a237a1ce4b8c12e90aadac67 /extra/libtorrent-rasterbar/PKGBUILD
parentb8afacf1f28ac27321feb9b92bd50dd8961b7736 (diff)
Wed Mar 7 00:01:25 UTC 2012
Diffstat (limited to 'extra/libtorrent-rasterbar/PKGBUILD')
-rw-r--r--extra/libtorrent-rasterbar/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/extra/libtorrent-rasterbar/PKGBUILD b/extra/libtorrent-rasterbar/PKGBUILD
index 9f7b84ac9..858b491b8 100644
--- a/extra/libtorrent-rasterbar/PKGBUILD
+++ b/extra/libtorrent-rasterbar/PKGBUILD
@@ -1,23 +1,27 @@
-# $Id: PKGBUILD 144057 2011-12-02 20:54:34Z ibiru $
+# $Id: PKGBUILD 152216 2012-03-05 08:56:15Z ibiru $
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgname=libtorrent-rasterbar
-pkgver=0.15.9
+pkgver=0.15.10
pkgrel=1
pkgdesc="A C++ library that aims to be a good alternative to all the other bittorrent implementations around"
url="http://www.rasterbar.com/products/libtorrent/"
arch=('i686' 'x86_64')
license=('custom')
-depends=('boost-libs' 'python2')
+depends=('boost-libs' 'geoip' 'python2')
makedepends=('boost')
options=('!libtool' '!emptydirs')
source=(http://libtorrent.googlecode.com/files/$pkgname-$pkgver.tar.gz)
-sha1sums=('d86eb9d4452d07715a355d3a67312f162d6eff3a')
+sha1sums=('3e461d9ede5fab3fb59be6a9f0cbc52121d536c4')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --enable-python-binding
+ export CFLAGS+=" -fvisibility=hidden"
+ export CXXFLAGS+=" -fvisibility=hidden"
+ ./configure --prefix=/usr \
+ --enable-python-binding \
+ --with-libgeoip=system
make
}