summaryrefslogtreecommitdiff
path: root/community/0ad/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/0ad/PKGBUILD')
-rw-r--r--community/0ad/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/0ad/PKGBUILD b/community/0ad/PKGBUILD
index 5721910ad..3bfd41435 100644
--- a/community/0ad/PKGBUILD
+++ b/community/0ad/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 112345 2014-06-01 02:33:08Z svenstaro $
+# $Id: PKGBUILD 113526 2014-06-24 20:55:12Z svenstaro $
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: t3ddy <t3ddy1988 "at" gmail {dot} com>
# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
pkgname=0ad
pkgver=a16
_pkgver=0.0.16-alpha
-pkgrel=2
+pkgrel=3
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game"
arch=('i686' 'x86_64')
url="http://play0ad.com/"
@@ -15,14 +15,19 @@ depends=('binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
'gloox' 'miniupnpc' 'icu' 'nspr')
makedepends=('boost' 'cmake' 'mesa' 'zip' 'python2' 'libsm')
source=("http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz"
- "http://trac.wildfiregames.com/raw-attachment/ticket/2552/miniupnpc_api.patch")
+ "http://trac.wildfiregames.com/raw-attachment/ticket/2552/miniupnpc_api.patch"
+ "gcc49-${pkgname}.patch::http://trac.wildfiregames.com/changeset/15334?format=diff&new=15334")
md5sums=('3836bbcdf4edc57c2354b4fef6023146'
- '6981595ba4b8eb21f9503304b090c9a9')
+ '6981595ba4b8eb21f9503304b090c9a9'
+ '5eda18c3f81cda68983bdeb7d7e20531')
prepare() {
cd "$srcdir/$pkgname-$_pkgver/"
- patch -p0 -i "../miniupnpc_api.patch"
+ patch -Np0 -i "../miniupnpc_api.patch"
sed -i "s/env python/env python2/g" libraries/source/cxxtest-4.3/bin/cxxtestgen
+
+ # Fix FS#40839
+ patch -Np3 -i "../gcc49-${pkgname}.patch"
}
build() {