summaryrefslogtreecommitdiff
path: root/community/gnuradio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnuradio/PKGBUILD')
-rw-r--r--community/gnuradio/PKGBUILD78
1 files changed, 39 insertions, 39 deletions
diff --git a/community/gnuradio/PKGBUILD b/community/gnuradio/PKGBUILD
index 84e7a847f..cc4f481b4 100644
--- a/community/gnuradio/PKGBUILD
+++ b/community/gnuradio/PKGBUILD
@@ -1,17 +1,18 @@
-# $Id: PKGBUILD 110873 2014-05-08 23:28:53Z kkeen $
+# $Id: PKGBUILD 115760 2014-07-16 04:39:04Z kkeen $
# Maintainer: Kyle Keen <keenerd@gmail.com>
# Contributor: Dominik Heidler <dheidler@gmail.com>
# Contributor: Jonatan Sastre <jsastreh [ at ] hotmail.com>
pkgname=gnuradio
-pkgver=3.7.3
-pkgrel=4
+pkgver=3.7.4
+pkgrel=1
pkgdesc="General purpose DSP and SDR toolkit. With drivers for usrp and fcd."
arch=('i686' 'x86_64')
url="http://gnuradio.org"
license=('GPL')
-depends=('fftw' 'python2-numpy' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.53' 'libusbx' 'portaudio' 'libuhd')
-makedepends=('boost' 'cmake' 'python2-lxml' 'pygtk' 'wxpython' 'python2-cheetah' 'glu' 'swig')
-optdepends=('python2-cheetah: gnuradio-companion'
+depends=('fftw' 'python2-numpy' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.53' 'libusbx' 'portaudio' 'libuhd' 'zeromq')
+makedepends=('boost' 'cmake' 'python2-lxml' 'pygtk' 'wxpython' 'python2-cheetah' 'glu' 'swig' )
+optdepends=('gnuradio-osmosdr: pile of driver blocks'
+ 'python2-cheetah: gnuradio-companion'
'python2-lxml: gnuradio-companion'
'pygtk: gnuradio-companion'
'wxpython: gr-wxgui'
@@ -32,7 +33,6 @@ install=gnuradio.install
# 'qwtplot3d'
# todo
-# add gr-osmosdr-git to optdepends
# split the gui components?
# build doxygen docs?
# icons
@@ -44,47 +44,47 @@ install=gnuradio.install
source=("http://gnuradio.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
"21-fcd.rules")
-md5sums=('a51e1c2860d6b289233e453d4085514f'
+md5sums=('94e7115ad7b46b5bc9e0b336cf74d8ba'
'465e12c454c6a22ebec9849181af7bdc')
build() {
- export PYTHON=python2
- cd "$srcdir/$pkgname-$pkgver"
- sed -i -e "s|GR_PKG_LIBEXEC_DIR|GR_RUNTIME_DIR|" grc/freedesktop/CMakeLists.txt
- sed -i -e "s|/qwt$|/qwt5|" -e "s| qwt | qwt5 |" cmake/Modules/FindQwt.cmake
- sed -i -e "s| sphinx-build$| sphinx-build2|" cmake/Modules/FindSphinx.cmake
- msg "Starting build."
- mkdir -p build
- cd build
- cmake \
- -DPYTHON_EXECUTABLE=$(which python2) \
- -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python2*) \
- -DPYTHON_LIBRARY=$(echo /usr/lib/libpython2.*.so) \
- -DENABLE_GRC=ON \
- -DENABLE_GR_WXGUI=ON \
- -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev ../
- make
+ export PYTHON=python2
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e "s|GR_PKG_LIBEXEC_DIR|GR_RUNTIME_DIR|" grc/freedesktop/CMakeLists.txt
+ sed -i -e "s|/qwt$|/qwt5|" -e "s| qwt | qwt5 |" cmake/Modules/FindQwt.cmake
+ sed -i -e "s| sphinx-build$| sphinx-build2|" cmake/Modules/FindSphinx.cmake
+ msg "Starting build."
+ mkdir -p build
+ cd build
+ cmake \
+ -DPYTHON_EXECUTABLE=$(which python2) \
+ -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python2*) \
+ -DPYTHON_LIBRARY=$(echo /usr/lib/libpython2.*.so) \
+ -DENABLE_GRC=ON \
+ -DENABLE_GR_WXGUI=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev ../
+ make
}
check() {
- cd "$srcdir/$pkgname-$pkgver/build"
- export PYTHON=python2
- #make test
+ cd "$srcdir/$pkgname-$pkgver/build"
+ export PYTHON=python2
+ #make test
}
package() {
- cd "$srcdir"
- install -Dm644 21-fcd.rules "$pkgdir/usr/lib/udev/rules.d/21-fcd.rules"
- cd "$srcdir/$pkgname-$pkgver/grc/freedesktop"
- install -Dm644 gnuradio-grc.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
- cd "$srcdir/$pkgname-$pkgver/build"
- make DESTDIR="$pkgdir" install
- msg "Replacing filenames to use python2."
- sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- $(find "$pkgdir" -name '*.py') \
- $(find "$pkgdir" -name 'gnuradio-companion' -o -name 'flow_graph.tmpl')
- find "$pkgdir/" -name '*.pyc' -delete
- find "$pkgdir/" -name '*.pyo' -delete
+ cd "$srcdir"
+ install -Dm644 21-fcd.rules "$pkgdir/usr/lib/udev/rules.d/21-fcd.rules"
+ cd "$srcdir/$pkgname-$pkgver/grc/freedesktop"
+ install -Dm644 gnuradio-grc.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ cd "$srcdir/$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+ msg "Replacing filenames to use python2."
+ sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find "$pkgdir" -name '*.py') \
+ $(find "$pkgdir" -name 'gnuradio-companion' -o -name 'flow_graph.tmpl')
+ find "$pkgdir/" -name '*.pyc' -delete
+ find "$pkgdir/" -name '*.pyo' -delete
}
# options for armv6: