summaryrefslogtreecommitdiff
path: root/community/haskell-pango/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/haskell-pango/PKGBUILD')
-rw-r--r--community/haskell-pango/PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/haskell-pango/PKGBUILD b/community/haskell-pango/PKGBUILD
index f5a94b19a..a968b112a 100644
--- a/community/haskell-pango/PKGBUILD
+++ b/community/haskell-pango/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 110626 2014-05-04 13:55:04Z td123 $
+# $Id: PKGBUILD 115985 2014-07-19 16:05:15Z td123 $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=haskell-pango
pkgver=0.12.5.3
-pkgrel=2
+pkgrel=3
pkgdesc="Binding to the pango library for Gtk2Hs."
url="http://hackage.haskell.org/package/pango"
license=('LGPL2.1')
@@ -32,11 +32,19 @@ build() {
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+_update_deps() {
+ _ver=`pacman -Q $1 | cut -f2 -d\ | cut -f1 -d-`
+ for i in `seq 0 $(expr ${#depends[@]} - 1)`; do
+ if [ ${depends[$i]} == $1 ]; then
+ depends[$i]="$1=${_ver}"
+ fi
+ done
+}
+
package() {
- _ghcver=`pacman -Q ghc | cut -f2 -d\ | cut -f1 -d-`
- _hglibver=`pacman -Q haskell-glib | cut -f2 -d\ | cut -f1 -d-`
- _hcairover=`pacman -Q haskell-cairo | cut -f2 -d\ | cut -f1 -d-`
- depends=("ghc=${_ghcver}" "pango" "haskell-glib=${_hglibver}" "haskell-cairo=${_hcairover}")
+ _update_deps ghc
+ _update_deps haskell-glib
+ _update_deps haskell-cairo
cd ${srcdir}/pango-${pkgver}
install -D -m744 register.sh ${pkgdir}/usr/share/haskell/gtk2hs-pango/register.sh