summaryrefslogtreecommitdiff
path: root/community/julia/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/julia/PKGBUILD')
-rw-r--r--community/julia/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/julia/PKGBUILD b/community/julia/PKGBUILD
index ebb9e558e..a1d909c53 100644
--- a/community/julia/PKGBUILD
+++ b/community/julia/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 111098 2014-05-13 18:30:47Z arodseth $
+# $Id: PKGBUILD 113118 2014-06-13 20:59:12Z arodseth $
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: Michael Jakl <jakl.michael@gmail.com>
@@ -6,18 +6,23 @@
pkgname=julia
pkgver=0.3.0_prerelease
-pkgrel=5
+pkgrel=6
pkgdesc='High-level, high-performance, dynamic programming language'
arch=('x86_64' 'i686')
url='http://julialang.org'
license=('GPL')
depends=('arpack' 'fftw' 'git' 'gmp' 'libunwind' 'mpfr' 'pcre' 'readline' 'zlib')
-makedepends=('gcc-fortran' 'python2' 'libuv')
+makedepends=('gcc-fortran' 'python2' 'libuv' 'setconf')
optdepends=('gnuplot: If using the Gaston Package from julia')
options=('!emptydirs' 'staticlibs')
source=("git://github.com/JuliaLang/julia.git#commit=3985890")
sha256sums=('SKIP')
+prepare() {
+ # Fix for FS#40736
+ [ $CARCH = x86_64 ] && (setconf "$pkgname/Make.inc" JULIA_CPU_TARGET core2) || true
+}
+
build() {
make -C "$pkgname" prefix=/usr sysconfdir=/etc \
USE_SYSTEM_LLVM=0 \