summaryrefslogtreecommitdiff
path: root/community/perl-test-leaktrace/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-test-leaktrace/PKGBUILD')
-rw-r--r--community/perl-test-leaktrace/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/perl-test-leaktrace/PKGBUILD b/community/perl-test-leaktrace/PKGBUILD
new file mode 100644
index 000000000..679fd8305
--- /dev/null
+++ b/community/perl-test-leaktrace/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 116275 2014-07-24 02:03:15Z fyan $
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname=perl-test-leaktrace
+pkgver=0.14
+pkgrel=2
+pkgdesc="Traces memory leaks"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+url='http://search.cpan.org/dist/Test-LeakTrace'
+source=('http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/Test-LeakTrace-0.14.tar.gz')
+sha512sums=('1bbd77bc2bc081a51b1f9fc946ece08bc5266efa41ac52d7216622b56ab2b122b419fdc0ba9f6a329eb506d6be56711b823310ef71b3171da0e13d4d3a8497d1')
+_distdir="Test-LeakTrace-0.14"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: