summaryrefslogtreecommitdiff
path: root/core/patch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/patch/PKGBUILD')
-rw-r--r--core/patch/PKGBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/core/patch/PKGBUILD b/core/patch/PKGBUILD
index 5d7b9f06a..5d352ba5a 100644
--- a/core/patch/PKGBUILD
+++ b/core/patch/PKGBUILD
@@ -1,43 +1,46 @@
-# $Id: PKGBUILD 174021 2013-01-01 15:15:16Z foutrelis $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id: PKGBUILD 216931 2014-07-16 17:04:51Z seblu $
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=patch
pkgver=2.7.1
-pkgrel=2
-pkgdesc="A utility to apply patch files to original sources"
+pkgrel=3
+pkgdesc='A utility to apply patch files to original sources'
arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/patch/patch.html"
+url='http://www.gnu.org/software/patch/patch.html'
license=('GPL')
groups=('base-devel')
-depends=('glibc')
+depends=('glibc' 'attr')
makedepends=('ed')
optdepends=('ed: for patch -e functionality')
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig}
- patch-2.7.1-initialize-data-structures-early-enough.patch)
+source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig}
+ 'patch-2.7.1-initialize-data-structures-early-enough.patch')
md5sums=('e9ae5393426d3ad783a300a338c09b72'
- 'b12189e0de3cb2af25268441647ec517'
+ 'SKIP'
'dc6367a7cd49933d4006c246789e98da')
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
+prepare() {
# Fix segfault on non-numeric strip-count
# (also segfaults on nonexistent directory passed to -d)
# http://savannah.gnu.org/bugs/?37500
- patch -Np1 -i \
- $srcdir/patch-2.7.1-initialize-data-structures-early-enough.patch
+ patch -Np1 -d $pkgname-$pkgver < patch-2.7.1-initialize-data-structures-early-enough.patch
+}
+build() {
+ cd $pkgname-$pkgver
./configure --prefix=/usr
make
}
check() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
make check
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=$pkgdir install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
+
+# vim:set ts=2 sw=2 et: