summaryrefslogtreecommitdiff
path: root/extra/cifs-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/cifs-utils/PKGBUILD')
-rw-r--r--extra/cifs-utils/PKGBUILD23
1 files changed, 19 insertions, 4 deletions
diff --git a/extra/cifs-utils/PKGBUILD b/extra/cifs-utils/PKGBUILD
index 951a2cf95..6ef93d3a2 100644
--- a/extra/cifs-utils/PKGBUILD
+++ b/extra/cifs-utils/PKGBUILD
@@ -1,14 +1,26 @@
-# $Id: PKGBUILD 214184 2014-06-04 12:03:07Z tpowa $
+# $Id: PKGBUILD 215193 2014-06-16 10:42:57Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=cifs-utils
pkgver=6.3
-pkgrel=1
+pkgrel=2
pkgdesc="CIFS filesystem user-space tools"
arch=(i686 x86_64)
url="http://wiki.samba.org/index.php/LinuxCIFS_utils"
license=('GPL')
depends=('libcap-ng' 'keyutils' 'krb5' 'talloc' 'libwbclient' 'pam')
-source=(ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/$pkgname-$pkgver.tar.bz2)
+source=(ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/$pkgname-$pkgver.tar.bz2
+ '0003-cifskey-better-use-snprintf.patch'
+ '0004-cifscreds-better-error-handling-when-key_search-fail.patch'
+ '0005-cifscreds-better-error-handling-for-key_add.patch')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # add fedora patches
+ # 40789 CVE-2014-2830
+ patch -Np1 -i "$srcdir/0003-cifskey-better-use-snprintf.patch"
+ patch -Np1 -i "$srcdir/0004-cifscreds-better-error-handling-when-key_search-fail.patch"
+ patch -Np1 -i "$srcdir/0005-cifscreds-better-error-handling-for-key_add.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -27,4 +39,7 @@ package() {
# set mount.cifs uid, to enable none root mounting form fstab
chmod +s $pkgdir/usr/bin/mount.cifs
}
-md5sums=('93697dbc043cb4d5c66e15e281f872e5')
+md5sums=('93697dbc043cb4d5c66e15e281f872e5'
+ 'cc13c6d1b734a446d0f4384e0ce32748'
+ '350491f336dc931f9b192228909e5924'
+ 'ac2b3367363fbc79f8f7fdfcae008a8c')