summaryrefslogtreecommitdiff
path: root/extra/ghc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/ghc/PKGBUILD')
-rw-r--r--extra/ghc/PKGBUILD69
1 files changed, 38 insertions, 31 deletions
diff --git a/extra/ghc/PKGBUILD b/extra/ghc/PKGBUILD
index f449f1785..183b99a45 100644
--- a/extra/ghc/PKGBUILD
+++ b/extra/ghc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 212771 2014-05-15 04:27:19Z td123 $
+# $Id: PKGBUILD 217481 2014-07-19 16:03:47Z td123 $
# Maintainer: Thomas Dziedzic <gostrc@gmail.com>
# Maintainer: Vesa Kaihlavirta <vesa@archlinux.org>
# Special note for devs looking to upgrade this package:
@@ -10,8 +10,8 @@
# grep -r ghc /var/abs/ | awk -F '/' '{ print $5; }' | sort -u
pkgname=ghc
-pkgver=7.8.2
-pkgrel=4
+pkgver=7.8.3
+pkgrel=2
pkgdesc='The Glasgow Haskell Compiler'
arch=('i686' 'x86_64')
url='http://www.haskell.org/ghc/'
@@ -22,7 +22,7 @@ checkdepends=('python2')
install='ghc.install'
options=('staticlibs')
provides=('haskell-array=0.5.0.0'
- 'haskell-base=4.7.0.0'
+ 'haskell-base=4.7.0.1'
'haskell-binary=0.7.1.0'
'haskell-bin-package-db=0.0.0.0'
'haskell-bytestring=0.10.4.0'
@@ -45,38 +45,45 @@ provides=('haskell-array=0.5.0.0'
'haskell-transformers=0.3.0.0'
'haskell-unix=2.7.0.1'
'haskell-cabal=1.18.1.3'
+ 'ghc=7.8.3-1'
+ 'haskell-haskeline=0.7.1.2'
+ 'haskell-terminfo=0.4.0.0'
+ 'haskell-xhtml=3000.2.1'
)
-replaces=('haskell-array<0.5.0.0'
- 'haskell-base<4.7.0.0'
- 'haskell-binary<0.7.1.0'
- 'haskell-bin-package-db<0.0.0.0'
- 'haskell-bytestring<0.10.4.0'
- 'haskell-containers<0.5.5.1'
- 'haskell-deepseq<1.3.0.2'
- 'haskell-directory<1.2.1.0'
- 'haskell-filepath<1.3.0.2'
- 'haskell-ghc-prim<0.3.1.0'
- 'haskell-haskell2010<1.1.2.0'
- 'haskell-haskell98<2.0.0.3'
- 'haskell-hoopl<3.10.0.1'
- 'haskell-hpc<0.6.0.1'
- 'haskell-integer-gmp<0.5.1.0'
- 'haskell-old-locale<1.0.0.6'
- 'haskell-old-time<1.1.0.2'
- 'haskell-pretty<1.1.1.1'
- 'haskell-process<1.2.0.0'
- 'haskell-template-haskell<2.9.0.0'
- 'haskell-time<1.4.2'
+replaces=('haskell-array'
+ 'haskell-base'
+ 'haskell-binary'
+ 'haskell-bin-package-db'
+ 'haskell-bytestring'
+ 'haskell-containers'
+ 'haskell-deepseq'
+ 'haskell-directory'
+ 'haskell-filepath'
+ 'haskell-ghc-prim'
+ 'haskell-haskell2010'
+ 'haskell-haskell98'
+ 'haskell-hoopl'
+ 'haskell-hpc'
+ 'haskell-integer-gmp'
+ 'haskell-old-locale'
+ 'haskell-old-time'
+ 'haskell-pretty'
+ 'haskell-process'
+ 'haskell-template-haskell'
+ 'haskell-time'
'haskell-transformers'
- 'haskell-unix<2.7.0.1'
- 'haskell-cabal<1.18.1.3'
+ 'haskell-unix'
+ 'haskell-cabal'
+ 'haskell-haskeline'
+ 'haskell-terminfo'
+ 'haskell-xhtml'
)
source=("http://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-src.tar.xz"
"http://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-testsuite.tar.xz"
'build.mk'
'ghc')
-md5sums=('97578e0c27574a99e0d5071a7f35d136'
- 'ac54f7fa453010149a573740705ecbfb'
+md5sums=('5e34b2a29564596c9ed83fb8667b47d4'
+ '7ca72a039d44ca2586c02863392b5dce'
'c367ef26300648ee9b8aca3dee5c9669'
'c1d46d86752c50dd85e7143b029fa07f')
@@ -88,7 +95,7 @@ build() {
./configure \
--prefix=/usr \
--with-system-libffi \
- --with-ffi-includes=/usr/lib/libffi-3.0.13/include
+ --with-ffi-includes=/usr/lib/libffi-3.1/include
make
}
@@ -135,7 +142,7 @@ package() {
${pkgdir}/usr/share/licenses/ghc
# provide non vanilla bash completion since ghc currently doesn't ship with any:
- # https://ghc.haskell.org/trac/ghc/ticket/9006
+ # https://ghc.haskell.org/trac/ghc/ticket/9005
install -d ${pkgdir}/usr/share/bash-completion/completions
install -m644 ${srcdir}/ghc \
${pkgdir}/usr/share/bash-completion/completions