summaryrefslogtreecommitdiff
path: root/extra/opencv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/opencv/PKGBUILD')
-rw-r--r--extra/opencv/PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/extra/opencv/PKGBUILD b/extra/opencv/PKGBUILD
index 9b0ef8867..24eb11287 100644
--- a/extra/opencv/PKGBUILD
+++ b/extra/opencv/PKGBUILD
@@ -1,12 +1,11 @@
-# $Id: PKGBUILD 213135 2014-05-19 14:16:07Z svenstaro $
+# $Id: PKGBUILD 215428 2014-06-24 20:06:31Z schiv $
# Maintainer: Ray Rashif <schiv@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
pkgbase=opencv
pkgname=('opencv' 'opencv-samples')
-_realname=OpenCV
-pkgver=2.4.8
-pkgrel=2
+pkgver=2.4.9
+pkgrel=1
pkgdesc="Open Source Computer Vision Library"
arch=('i686' 'x86_64')
license=('BSD')
@@ -21,7 +20,7 @@ optdepends=('opencv-samples'
source=("http://downloads.sourceforge.net/opencvlibrary/$pkgname-$pkgver.zip"
'pkgconfig.patch'
'fsh.patch')
-md5sums=('50cc1433b3654074206f5b3dbfd49848'
+md5sums=('7f958389e71c77abdf5efe1da988b80c'
'c7cea48ed7d4f729ebdb9673bac41bd3'
'c597598d142dd34d0eb4af7d6e9779d8')
@@ -51,15 +50,16 @@ _cmakeopts=('-D WITH_OPENCL=ON'
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- # hack-fix pkg-config mess
+ msg2 "Fixing broken pkg-config (downstream)"
# see https://bugs.archlinux.org/task/32430
# and http://code.opencv.org/issues/1925
patch -Np1 -i "$srcdir/pkgconfig.patch"
- # hack-fix folder naming inconsistency that they won't fix
+ # TODO: this is mostly upstream frei0r; they hardcode the path
+ #msg2 "Hack-fixing folder naming inconsistency (downstream)"
# see http://code.opencv.org/issues/2512
# and https://bugs.archlinux.org/task/32342
- patch -Np1 -i "$srcdir/fsh.patch"
+ #patch -Np1 -i "$srcdir/fsh.patch"
# no longer including docs, see https://bugs.archlinux.org/task/34185
# python2 compatibility for generating (html) docs
@@ -82,16 +82,17 @@ package_opencv() {
make DESTDIR="$pkgdir" install
# install license file
- install -Dm644 "$srcdir/$pkgname-$pkgver/doc/license.txt" \
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$pkgdir/usr/share"
# separate samples package; also be -R friendly
- if [[ -d $pkgname/samples ]]; then
- mv $pkgname/samples "$srcdir/opencv-samples"
- elif [[ -d $_realname ]]; then
- warn "Directory naming issue; samples package may not be built!"
+ if [[ -d OpenCV/samples ]]; then
+ mv OpenCV/samples "$srcdir/$pkgname-samples"
+ mv OpenCV $pkgname # otherwise folder naming is inconsistent
+ elif [[ ! -d OpenCV ]]; then
+ warning "Directory naming issue; samples package may not be built!"
fi
}
@@ -104,7 +105,7 @@ package_opencv-samples() {
cp -r "$srcdir/opencv-samples" "$pkgdir/usr/share/opencv/samples"
# install license file
- install -Dm644 "$srcdir/opencv-$pkgver/doc/license.txt" \
+ install -Dm644 "$srcdir/opencv-$pkgver/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}