summaryrefslogtreecommitdiff
path: root/libre/vhba-module/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/vhba-module/PKGBUILD')
-rw-r--r--libre/vhba-module/PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/libre/vhba-module/PKGBUILD b/libre/vhba-module/PKGBUILD
index 714f60f99..f97c18655 100644
--- a/libre/vhba-module/PKGBUILD
+++ b/libre/vhba-module/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer (Arch): Ray Rashif <schiv@archlinux.org>
-# Contributor (Arch): Mateusz Herych <heniekk@gmail.com>
-# Contributor (Arch): Charles Lindsay <charles@chaoslizard.org>
-# Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
-# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
+# Contributor: Ray Rashif <schiv@archlinux.org>
+# Contributor: Mateusz Herych <heniekk@gmail.com>
+# Contributor: Charles Lindsay <charles@chaoslizard.org>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.5.13-1
+_basekernel=5.12.6
pkgbase=vhba-module
pkgname=(vhba-module vhba-module-dkms)
-pkgver=20200106
-pkgrel=26
+pkgver=20210418
+pkgrel=15
pkgrel+=.parabola1.basekernel${_basekernel%-*}
pkgdesc="Kernel module that emulates SCSI devices"
pkgdesc+=" (built for the linux-libre kernel package)"
url="https://cdemu.sourceforge.io/"
arch=(x86_64)
-arch+=(i686 armv7h)
+arch+=(i686)
license=(GPL)
makedepends=(linux-libre-headers=${_basekernel%-*} git libelf)
-source=("https://downloads.sourceforge.net/cdemu/$pkgbase-$pkgver.tar.bz2"
+source=("https://downloads.sourceforge.net/cdemu/$pkgbase-$pkgver.tar.xz"
60-vhba.rules dkms.conf)
-sha256sums=('59a3208a7b8fcf1bb03bd4d352ec89d06a8b6b84db325e31b0863b209dde3483'
+sha256sums=('18bd82ae27721ad1612b3c31accd81898ae326370964385ca52a2a66b67a3f85'
'3052cb1cadbdf4bfb0b588bb8ed80691940d8dd63dc5502943d597eaf9f40c3b'
'8cab0ebb4fee72069d63616b0983f105b98d1261e72e9bef5509a6e60bc382a7')
@@ -37,6 +37,7 @@ build() {
package_vhba-module() {
depends=(linux-libre=${_basekernel%-*})
+ provides=(VHBA-MODULE)
local extradir="/usr/lib/modules/$(</usr/src/linux-libre/version)/extramodules"
cd $pkgbase-$pkgver
@@ -44,12 +45,13 @@ package_vhba-module() {
install -Dt "$pkgdir/usr/lib/udev/rules.d" -m644 ../60-vhba.rules
echo 'g cdemu - -' | install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/cdemu.conf"
+ find "$pkgdir" -name '*.ko' -exec strip --strip-debug {} +
find "$pkgdir" -name '*.ko' -exec xz {} +
}
package_vhba-module-dkms() {
depends=(dkms)
- provides=("vhba-module=$pkgver-${pkgrel%%.*}")
+ provides=(VHBA-MODULE)
conflicts=(vhba-module)
cd $pkgbase-$pkgver