summaryrefslogtreecommitdiff
path: root/src/chroot-tools
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 14:46:36 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:54:01 -0500
commitdc9339b5699ee3b0d48145a1389f93e9e09d02a6 (patch)
treeed71bd691ea6e0d05d47e2bfd891c333bf5709ab /src/chroot-tools
parent4f9203808ef9607ae27eba3cf77079bbe661fd95 (diff)
Update and tidy the build system for autothing v3.
Diffstat (limited to 'src/chroot-tools')
l---------src/chroot-tools/GNUmakefile1
-rw-r--r--src/chroot-tools/Makefile19
2 files changed, 11 insertions, 9 deletions
diff --git a/src/chroot-tools/GNUmakefile b/src/chroot-tools/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/chroot-tools/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 96fb837..93655d7 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -1,27 +1,28 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkglibexecdir = $(libexecdir)/libretools/chroot
-libretools-bins = chcleanup librechroot libremakepkg
-libretools-libexecs += arch-nspawn chcleanup distcc-tool indent mkarchroot
-libretools-libs += makechrootpkg.sh
-devtools-files = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
-std.clean_files += chcleanup.lib
+libretools.src.devtools = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
+libretools.out.bins = chcleanup librechroot libremakepkg
+libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
+libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
+files.out.int += chcleanup.lib
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/%.sh.in: $(devtoolsdir)/%.in
cp $< $@
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
- m4 -I$(@D) -P $< | $(edit) | install -m755 /dev/stdin $@
+ m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@
$(outdir)/chcleanup.lib: $(call at.path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
bash -c '. $<; declare -f _l plain msg msg2 error' > $@
$(outdir)/distcc-tool.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage
-$(DESTDIR)$(bindir)/chcleanup: $(var)bindir $(var)libexecdir
- mkdir -p $(@D)
+$(DESTDIR)$(bindir)/chcleanup: $(var.)bindir $(var.)libexecdir
+ $(MKDIR_P) $(@D)
ln -srfT $(DESTDIR)$(libexecdir)/libretools/chroot/chcleanup $@
-at.depdirs += ../lib
+at.subdirs += ../lib
include $(topsrcdir)/build-aux/Makefile.tail.mk