summaryrefslogtreecommitdiff
path: root/src/devtools
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 14:46:36 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:54:01 -0500
commitdc9339b5699ee3b0d48145a1389f93e9e09d02a6 (patch)
treeed71bd691ea6e0d05d47e2bfd891c333bf5709ab /src/devtools
parent4f9203808ef9607ae27eba3cf77079bbe661fd95 (diff)
Update and tidy the build system for autothing v3.
Diffstat (limited to 'src/devtools')
-rw-r--r--src/devtools/.gitignore1
l---------src/devtools/GNUmakefile1
-rw-r--r--src/devtools/Makefile8
3 files changed, 6 insertions, 4 deletions
diff --git a/src/devtools/.gitignore b/src/devtools/.gitignore
index d669bbd..b9fef64 100644
--- a/src/devtools/.gitignore
+++ b/src/devtools/.gitignore
@@ -1,4 +1,5 @@
*
+!GNUmakefile
!Makefile
!.gitignore
!*.patch
diff --git a/src/devtools/GNUmakefile b/src/devtools/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/devtools/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 6d3f88c..4b7af11 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,12 +1,12 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools-bins += checkpkg find-libdeps finddeps lddd
-devtools-files = $(addsuffix .in,$(libretools-bins))
-std.sys_files += $(bindir)/find-libprovides
+libretools.out.bins = checkpkg find-libdeps finddeps lddd
+libretools.src.devtools = $(addsuffix .in,$(libretools.out.bins))
+files.sys.all += $(bindir)/find-libprovides
$(DESTDIR)$(bindir)/find-libprovides:
- install -d $(@D)
+ $(MKDIR_P) $(@D)
ln -sf find-libdeps $@
include $(topsrcdir)/build-aux/Makefile.tail.mk