summaryrefslogtreecommitdiff
path: root/src/devtools
diff options
context:
space:
mode:
Diffstat (limited to 'src/devtools')
-rw-r--r--src/devtools/.gitignore1
l---------src/devtools/GNUmakefile1
-rw-r--r--src/devtools/Makefile8
3 files changed, 6 insertions, 4 deletions
diff --git a/src/devtools/.gitignore b/src/devtools/.gitignore
index d669bbd..b9fef64 100644
--- a/src/devtools/.gitignore
+++ b/src/devtools/.gitignore
@@ -1,4 +1,5 @@
*
+!GNUmakefile
!Makefile
!.gitignore
!*.patch
diff --git a/src/devtools/GNUmakefile b/src/devtools/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/devtools/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 6d3f88c..4b7af11 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,12 +1,12 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools-bins += checkpkg find-libdeps finddeps lddd
-devtools-files = $(addsuffix .in,$(libretools-bins))
-std.sys_files += $(bindir)/find-libprovides
+libretools.out.bins = checkpkg find-libdeps finddeps lddd
+libretools.src.devtools = $(addsuffix .in,$(libretools.out.bins))
+files.sys.all += $(bindir)/find-libprovides
$(DESTDIR)$(bindir)/find-libprovides:
- install -d $(@D)
+ $(MKDIR_P) $(@D)
ln -sf find-libdeps $@
include $(topsrcdir)/build-aux/Makefile.tail.mk